<< Вернуться у выбору материала

5.2. Интеграция IDEF0- и IDEF1X-моделей и связывание объектов модели данных со стрелками и работами

Введите ваш запрос для начала поиска.

BPwin позволяет связывать модели данных (ER-диаграммы) с функциональными моделями, определяя при этом влияние работ (функциональных блоков) на данные и позволяя создавать спецификации на права доступа к данным для каждого процесса.

Модель данных, открытая в ERwin

Рис. 18. Модель данных, открытая в ERwin

Первым шагом связывания модели данных и функциональной модели является экспорт данных из ERwin в BPwin. Для этого используем способ импорта через файлы формата .ЕАХ - .ВРХ.

Для экспорта модели данных из ERwin в BPwin необходимо в ERwin открыть модель (рис. 18) и выбрать пункт меню File/Export/BPwin. В появившемся диалоге Select BPwin Export File необходимо выбрать каталог, вставить имя создаваемого файла экспорта с расширением *.еах и нажать “Сохранить”. Затем в BPwin нужно открыть модель процессов (рис. 19) и выбрать в меню пункт File/Import/ERwin (EAX). Затем в диалоге Open выбрать имя файла с расширением *.еах и нажать “Открыть”.

Функциональная IDEF0-модель

Рис. 19. Функциональная IDEF0-модель

Появится диалог Import Differences Preview, в котором показывается протокол импорта (рис. 20). Для внесения данных в модель процессов следует щелкнуть по кнопке Accept. Кнопка Cancel отменяет импорт.

После внесения модели данных в BPwin можно связать сущности и атрибуты со стрелками. Правой кнопкой мыши нужно щелкнуть по любой стрелке (например, по стрелке ценники) функциональной модели (рис. 19) и выбрать в контекстном меню Arrow Data.

Появляется вкладка Arrow Data диалога Arrow Properties (рис. 21).

Диалог Import Differences Preview

Рис. 20. Диалог Import Differences Preview

Вкладка Arrow Data диалога Arrow Property для стрелки цен-ники

Рис. 21. Вкладка Arrow Data диалога Arrow Property для стрелки ценники

Для связывания атрибута с выбранной стрелкой достаточно щелкнуть по иконкам выбора иконка выбора в иерархическом списке соответствующих атрибутов на рис. 21 они отмечены галочкой. При этом сущность автоматически связывается со стрелкой. Каждая стрелка в модели процессов может быть связана с несколькими атрибутами различных сущностей (рис. 25).

Следует также учесть воздействие функциональных блоков на данные, то есть они определяют, какие данные для них являются входящими и исходящими. Для документирования такого воздействия необходимо щелкнуть правой клавишей мыши по блоку и в появившемся контекстном меню выбрать пункт меню Data Usage Editor.

В появившемся диалоге Data Usage Editor (рис. 22) в виде иерархического списка показываются все функциональные блоки модели (учет продаж, учет товара), стрелки (ценники, накладная в торговый зал, накладная поставщика и др.), которые касаются блоков, сущности (prodavec, tovar, zakaz) и атрибуты (fio, cena, nazv и др.), которые были связаны со стрелками. Для задания ассоциации достаточно щелкнуть по окну задание ассоциации в иерархическом списке.

Диалог BPwin Data Usage Editor

Рис. 22. Диалог BPwin Data Usage Editor

Диалоговое окно для формирования отчетов по результатам связывания функциональной и информационной моделей

Рис. 23. Диалоговое окно для формирования отчетов по результатам связывания функциональной и информационной моделей

В окне Standarts Reports можно установить пять видов отчетов, указать их формат (в группе Report Format) и задать состав полей и их порядок следования в отчете.

На рисунке 23 установлены опции отчета, показанного на рис. 26 (вид отчета – Activity Entity Attribute Association). Этот вариант отчета позволяет определить, какие атрибуты сущностей задействованы в стрелках.

На рисунках 24, 25 приведены другие установки опций в окне Data Usage Report.

Отчет о связях функциональных блоков с сущностями и атрибутами.

Рис. 24. Отчет о связях функциональных блоков с сущностями и атрибутами.

Отчет о связях функциональных блоков с дугами, сущностями и атрибутами.

Рис. 25. Отчет о связях функциональных блоков с дугами, сущностями и атрибутами.

Отчет о связях стрелок с сущностями и атрибутами.

Рис. 26. Отчет о связях стрелок с сущностями и атрибутами.

Анализов отчетов (рис. 26) и диалоговых окон (рис. 21) позволяет определить те атрибуты, которые не используются во входных и выходных документах, а, следовательно, являются лишними, если в них не планируется хранение каких либо вычисляемых при эксплуатации данных.

Отсутствие необходимых атрибутов будет проявляться в невозможности установления соответствия какой-либо информации, связанной со стрелками, и атрибута. В этом случае имеется возможность создать недостающий атрибут и даже сущности не покидая пакета BPwin.

Если в процессе связывания стрелок с объектами модели данных окажется, что каких-либо сущностей или атрибутов не хватает, их можно добавить прямо в BPwin с помощью команды Model/Entity/Attribute Editor (рис. 27), а затем экспортировать в ERwin.

Пример добавления атрибута data_izgot в сущность tovar

Рис. 27. Пример добавления атрибута data_izgot в сущность tovar

Если в модель данных были внесены изменения, то для ее экспорта из BPwin следует выбрать команду File/Export/ERwin (ВРХ) и указать имя нового файл, в который будет "выгружена" информация об измененной информационной модели.

В ERwin следует выбрать меню File/Import/BPwin и в диалоге ERwin Open File указать файл ВРХ, в который была "выгружена" информация о модели. Возникает диалог ERwin/BPwin Import, в котором отображаются сущности и атрибуты, имеющиеся в ВРХ-файле, но отсутствующие в модели ERwin

После щелчка по кнопке Import запускается процесс импорта ВРХ-файла и получаем сущность tovar с новым атрибутом data_izgot (рис. 28).

Если будет импортироваться вновь созданная сущность, то она не будет иметь первичного ключа и не будет связана с другими сущностями. Назначение атрибутов первичным ключом и связывание сущностей можно провести только средствами ERwin.

Модифицированная в BPwin ER-диаграмма

Рис. 28. Модифицированная в BPwin ER-диаграмма

Рейтинг@Mail.ru